Dica: Update Pacman 4.1

Olá pessoal, hoje venho compartilhar uma pequena dica com vocês. Pela manhã fui atualizar o meu Arch e me deparei com a seguinte mensagem:

erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: package-query: requer pacman<4.1

Para contornar isso, que a meu ver não se caracteriza como quebra de pacote, primeiro removi o pacote conflitante e suas dependências, no caso:

pacman -R package-query yaourt

Em seguida atualizei o sistema:

pacman -Syu

Depois, renomeei o pacman.conf.pacnew:

mv /etc/pacman.conf.pacnew /etc/pacman.conf

Atualizei novamente o sistema com a nova configuração do pacman.conf:

pacman -Syu

E para finalizar, instalei novamente o yaourt e package-query.

Dica: Quando ocorre algo dessa forma ou parecido com algum pacote, primeiro eu removo o pacote conflitante com suas dependências e faço a atualização, caso seja bem sucedida a atualização instalo novamente o pacote removido.

Nada demais não é mesmo?

 

AFK

4 Comentários

  1. brother meu erro eh o opostos :/

    na hora de instalar o query da esse erro de dependencia pacman<4.1 como instalar?

  2. esquece consegui peguei um pacote errado 😉

Deixe uma resposta para Danilo Turqueti Cancelar resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

%d blogueiros gostam disto: